nixos-config/hosts/qemu-vm.nix
Sravan Balaji 59f88dad0f Re-organize Nix Modules
- Move all programs into system folder
- Create `default.nix` for each folder to reduce number of imports
  in configuration.nix
- Rename some modules to be more generic and less package
  specific to allow for easy swapping of programs in the future
- Update flake.lock
2024-03-27 16:12:10 -04:00

25 lines
1020 B
Nix

# Do not modify this file! It was generated by 'nixos-generate-config'
# and may be overwritten by future invocations. Please make changes
# to /etc/nixos/configuration.nix instead.
{ config, lib, pkgs, modulesPath, ... }:
{
imports =
[ (modulesPath + "/profiles/qemu-guest.nix")
];
boot.initrd.availableKernelModules = [ "ahci" "xhci_pci" "virtio_pci" "sr_mod" "virtio_blk" ];
boot.initrd.kernelModules = [ ];
boot.kernelModules = [ "kvm-intel" ];
boot.extraModulePackages = [ ];
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
# (the default) this is the recommended approach. When using systemd-networkd it's
# still possible to use this option, but it's recommended to use it in conjunction
# with explicit per-interface declarations with 'networking.interfaces.<interface>.useDHCP'.
networking.useDHCP = lib.mkDefault true;
# networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
}