Sravan Balaji 7db963f519 Gui Reorg and More Programs
- Gui config reorganization
- Enable picom for dwm
- Install some utilities like arandr, autorandr, and unclutter-xfixes
  for dwm
- Add nerdfonts for FiraCode
- Remove conditional imports list syntax
- Add audio tools like playerctl and pavucontrol
- Enable polkit and add GNOME polkit
- Add more media programs like freecad, audacity, ani-cli, and calibre
- Add flameshot
2024-03-28 20:16:07 -04:00

19 lines
402 B
Nix

{ config, lib, pkgs, systemSettings, ... }:
{
imports = [
./default.nix
];
services.xserver.displayManager = {
sddm = {
enable = true;
wayland.enable = (if systemSettings.desktopType == "x11" then false else true);
};
defaultSession = (if systemSettings.desktopType == "x11" then "plasmax11" else "plasma");
};
services.desktopManager.plasma6.enable = true;
}